cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Dijkshoorn <peter.dijksho...@adyen.com>
Subject count after truncate NOT zero
Date Thu, 03 May 2012 13:28:45 GMT
Hi guys,

I got a weird thingy popping up twice today, I run a test where I insert
a milion records via YCSB and edited it to allow me to adjust the
consistency level: the write operations are done with ConsistencyLevel.ALL.
This is send to a 4 (virtual) node cluster with a keyspace 'test' set up
with replication factor 3.
Now I expect that because of the ConsistencyLevel.ALL there is no hinted
handoff active, since writes are to be accepted by all nodes before the
operation returns to the client. The client gets only OK back, none fails.
After the test I run a truncate, and a count which reveals still active
records, time does not matter, I have to re-invoke the truncate to
remove the records.

[cqlsh 2.0.0 | Cassandra 1.0.8 | CQL spec 2.0.0 | Thrift protocol 19.20.0]
cqlsh> use test;
cqlsh:test> truncate usertable;
cqlsh:test> select count(*) from usertable ;
 count
-------
     3


On the cassandra output (-f) I can see that there is some handoff-ing
active, which I did not expect.

Has anyone an idea why the handoff is active while issuing opperations
with ConsistencyLevel.ALL?
Why is the truncate not correctly put in sync and allows subsequent
handoff's delivered of records originally set before the truncate?

Thanks if you can clarify these thing, I did not expect this at all.

Cheers,

Peter

-- 
Peter Dijkshoorn
Adyen - Payments Made Easy
www.adyen.com

Visiting address:    	        Mail Address:             
Simon Carmiggeltstraat 6-50    	P.O. Box 10095
1011 DJ Amsterdam               1001 EB Amsterdam
The Netherlands                 The Netherlands

Office +31.20.240.1240
Email peter.dijkshoorn@adyen.com


Mime
View raw message