cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aditya Gupta <ady...@gmail.com>
Subject Re: Only the last added node is visible in the cluster
Date Sat, 25 Feb 2012 21:39:16 GMT
The output of nodetool ring after each addition of nodes, make just the
last added node visible in the ring.
When I retry to add the node(which are not visible) it says that it is
already a part of the ring.

Could you indicate how should I rectify this now, as you seem to have
figured out the issue ?

On Sun, Feb 26, 2012 at 2:49 AM, Aditya Gupta <adynnn@gmail.com> wrote:

> yes, exactly I did cloned a single  VMware  machine to make other
> instances.. so how do I correct this now ?
>
>
> On Sun, Feb 26, 2012 at 2:18 AM, Brandon Williams <driftx@gmail.com>wrote:
>
>> Then my next guess is you cloned one system to make the others in a
>> virtual env, and the token is recorded in the system keyspace.  In any
>> case, some nodetool ring output at each node addition will clarify
>> this.
>>
>> -Brandon
>>
>> On Sat, Feb 25, 2012 at 1:20 PM, Aditya Gupta <adynnn@gmail.com> wrote:
>> > Nope, I just re-verified :)
>> > I have split up the range into 4 parts for 4 nodes. I have specified
>> that in
>> > the intial_token
>> >
>> >
>> > On Sun, Feb 26, 2012 at 12:33 AM, Brandon Williams <driftx@gmail.com>
>> wrote:
>> >>
>> >> My guess would be you're using the same token everywhere.
>> >>
>> >> -Brandon
>> >>
>> >> On Sat, Feb 25, 2012 at 9:48 AM, Aditya Gupta <adynnn@gmail.com>
>> wrote:
>> >> > While creating a multinode cluster, my nodes are unable to identify
>> all
>> >> > the
>> >> > nodes in the cluster.
>> >> > Only the *last added'  node is visible when I do:
>> >> >  ./nodetool -h localhost ring
>> >> >
>> >> >
>> >> > I am trying to create a 4 nodes cluster. On starting the seed node,
>> the
>> >> > above command shows just itself(ok.. good), then when I start the 2nd
>> >> > node
>> >> > the first one disappears & there is only 2nd visible in the ring.
On
>> >> > starting 3rd one, just the 3rd one remains.
>> >> >
>> >> > In cassandra.yaml of each node, I configured the listen_adress equal
>> to
>> >> > ip
>> >> > address of that node & for seeds I just put the ip address of 1st
>> node
>> >> > everywhere.
>> >> >
>> >> > Can anyone point to me what may be causing this ?
>> >> >
>> >
>> >
>>
>
>

Mime
View raw message