cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aaron morton <aa...@thelastpickle.com>
Subject Re: Minor version upgrade and SSTable compatibilty
Date Sun, 08 Jan 2012 21:39:10 GMT
> 1. Will I need to upgrade all nodes before performing streaming/repair?
AFAIK if they are all at least 1.0.3 you can, as compatibility and stream capability is based
on the major version. 

> 2. Will it be possible to downgrade a node from 1.0.6 to 1.0.3 and keep newly created
SSTables? Or will I then have to revert to a pre-upgrade snapshot?
AFAIK you can. 

*NOTE:* This is from a quick look through the code, anyone else confirm this ? 

Cheers

-----------------
Aaron Morton
Freelance Developer
@aaronmorton
http://www.thelastpickle.com

On 8/01/2012, at 4:13 AM, Jonas Borgström wrote:

> Hi,
> 
> I have some questions about SSTable compatibility when doing a minor version upgrade.
For example when upgrading from 1.0.3 (Uses version "hb") to 1.0.6 (uses version "hc").
> 
> 1. Will I need to upgrade all nodes before performing streaming/repair?
> 
> 2. Will it be possible to downgrade a node from 1.0.6 to 1.0.3 and keep newly created
SSTables? Or will I then have to revert to a pre-upgrade snapshot?
> 
> / Jonas
> 
> 


Mime
View raw message