cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jahangir Mohammed <md.jahangi...@gmail.com>
Subject Re: timeout while doing repair
Date Thu, 24 Nov 2011 13:59:46 GMT
Do you use any client which gives you this timeout ?

If you don't specify any timeout from client, look at rpc_timeout_in_ms.
Increase it and see if you still suffer this.

Repair is a costly process.

Thanks,
Jahangir Mohammed.



On Thu, Nov 24, 2011 at 2:45 AM, Patrik Modesto <patrik.modesto@gmail.com>wrote:

> Hi,
>
> I have a test cluster of 4 nodes running Debian and Cassandra 0.8.7,
> there are 3 keyspaces, all with RF=3, a node has load around 40GB.
> When I run "nodetool repair" after a while all thrift clients that
> read with CL.QUORUM get TimeoutException and even some that use just
> CL.ONE. I've tried to run repair on just one keyspace and read from
> other keyspace, but I still get the TimeoutException.
>
> I tried to tune compaction_throughput_mb_per_sec and
> concurrent_compactors but without success. The same problem is
> happening on our production cluster of 8 nodes (same setup).
>
> Where may be the problem?
>
> Regards,
> Patrik
>

Mime
View raw message