cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From huyle <>
Subject Random CPU usage at 100% and load spikes > 300
Date Tue, 22 Nov 2011 17:36:16 GMT

After upgrading to 1.0.3, we have been experiencing random cpu usage spikes
to 100% and CPU load on a 2 cores EC2 m1.large instance spikes to > 300
rendering the system unresponsive.  This load pikes runs for 5 to 10 minutes
and it recovered after.  We tuned concurrent compactor to 1 and set
compactor throughput to 4mb, but it's still no helping.  

Currently we have one of the 12 nodes that will ramp CPU usage to 100%
within a minute of joining cluster.  The node has full compaction, so there
is just single data file for each CF.  Data size on this node is 57GB. 
Tried using JVM size of 3, 4, 5GB, and all gives the same issue.  The same
goes with JNA, enable/disable JNA does not help.

This is on a cluster of 12 nodes with RF=3.  

Does anyone have any idea what might be causing these loads?  Thanks!


View this message in context:
Sent from the mailing list archive at

View raw message