cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pete Warden <>
Subject pig_cassandra problem - "Incompatible field schema" error
Date Tue, 11 Oct 2011 21:24:28 GMT
I'm trying to run the most basic example for pig_cassandra, counting the
number of rows in a column family, and I'm hitting the following error:

2011-10-11 14:13:32,321 [main] ERROR -
ERROR 1031: Incompatable field schema: left is
"columns:bag{:tuple(name:bytearray,value:bytearray)}", right is

I've tried it with various column families, with the same result, but here's
the definition of this one:

create column family FriendsAlreadyRanked with
  comparator = UTF8Type and
  column_metadata =
    {column_name: time_last_ranked, validation_class: UTF8Type},

Here's the command I'm running from within pig_cassandra:

rows = LOAD 'cassandra://Frap/FriendsAlreadyRanked' USING CassandraStorage()
AS (key, columns:bag{T: tuple(name, value)});

Here's my versions:

Apache Pig version 0.9.1 (r1177456)

Cassandra 0.8.1

Any thoughts on how to troubleshoot this? It's obviously connecting to
Cassandra since it pulls out the column family definition, so I'm guessing
it's a Pig type definition problem, but I haven't figured out what it
expects (and all the examples just use the form above).



View raw message