cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ramesh S <>
Subject Re: unable to start as a service on Ubuntu server
Date Tue, 27 Sep 2011 22:49:43 GMT
Thanks Konstantin.

I checked the services, but it doesn't show up for some reason. Even trying
to connect locally or remotely using a CLI client, returned
Exception connecting to xx.xx.xx.xx/9160. Reason: Connection refused.
But I tried sudo cassandra start and it worked like a charm.
I am surprised why omitting the 'service' did the job.
It is development server, but I am little concerned about the production


On Tue, Sep 27, 2011 at 5:12 PM, Konstantin Naryshkin

> Yes, they start Cassandra as a daemon in the background. It is running. You
> can connect to it from the CLI or any other client. You can see what it is
> doing by reading the logs. cassandra -f starts Cassandra in the foreground,
> that is why it does not return a prompt when the server starts.
> ----- Original Message -----
> From: "Ramesh S" <>
> To:
> Sent: Tuesday, September 27, 2011 5:03:12 PM
> Subject: unable to start as a service on Ubuntu server
> Hello all,
> We installed Cassandra on our development server , which is a fresh Ubuntu
> server running only Cassandra.
> We followed all the instructions on this link and when we want to start the
> server as a service by issuing either of the command.
> service cassandra start
> /etc/init.d/cassandra start
> it waits for a few seconds, then returns the prompt.
> But the service never starts.
> When we try to start with cassandra -f , it works fine.
> What could be the issue.
> Any help would be appreciated.
> many thanks

View raw message