cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Ellis <jbel...@gmail.com>
Subject Re: Bulk loader: Got an unknow host from describe_ring
Date Thu, 01 Sep 2011 21:34:52 GMT
Sounds like https://issues.apache.org/jira/browse/CASSANDRA-3044,
fixed for 0.8.5

On Thu, Sep 1, 2011 at 4:27 PM, Christopher Bottaro
<cjbottaro@onespot.com> wrote:
> Hello,
> I'm trying to import data from one Cassandra cluster to another.  The old
> cluster is using ports 7000 and 9160 and the new cluster is using 7001 and
> 9161.  I ran "nodetool -h localhost snapshot" on a node on the old cluster.
>  I then downloaded apache-cassandra-0.8.4-bin.tar.gz, edited
> conf/cassandra.yaml appropriately for the new cluster, exported
> CASSANDRA_INCLUDE=bin/cassandra.sh.in (so it doesn't try to use the
> installed, running Cassandra).
> When I run sstableloader, I can see that it's connecting to the new cluster
> (by tailing the logs), but after a few seconds, it gives the error: "Got an
> unknow host from describe_ring"
> After banging my head for a while, I scp'ed the snapshotted data to a node
> on the *new* cluster.  I again downloaded apache-cassandra-0.8.4-bin.tar.gz
> and configured cassandra.yaml there appropriately (with listen_address:
> 127.0.0.1 so as to not conflict with the Cassandra already running on the
> node).
> Running sstableloader resulted in the same error.
> "nodetool -h localhost ring" shows a healthy cluster.  Running that command
> works both locally and remotely.  I can connect to the cluster using
> cassandra-cli both locally and remotely as well.
> Any ideas?  Thanks for the help.



-- 
Jonathan Ellis
Project Chair, Apache Cassandra
co-founder of DataStax, the source for professional Cassandra support
http://www.datastax.com

Mime
View raw message