I set up a Cassandra project in Eclipse following http://wiki.apache.org/cassandra/RunningCassandraInEclipse
Then, I made a few modifications on it to form a customised Cassandra.
But I don't know how can I release this new Cassandra from Eclipse as a jar file to use in EC2.

I tried "ant release" command in command line. It can successful build .jar file.
Then I typed java -jar apache-cassandra-0.7.0-beta1-SNAPSHOT.jar

"Error: Failed to load Main-Class manifest attribute from "

I edited a MANIFEST.MF like:
Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.1
Created-By: 16.3-b01 (Sun Microsystems Inc.)
Implementation-Title: Cassandra
Implementation-Version: 0.7.0-beta1-SNAPSHOT
Implementation-Vendor: Apache
Main-Class: org.apache.cassandra.thrift.CassandraDaemon

and tried again. the error is like below:

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/thrift/transport/TTransportException
Caused by: java.lang.ClassNotFoundException: org.apache.thrift.transport.TTransportException
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:264)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:332)
Could not find the main class: org.apache.cassandra.thrift.CassandraDaemon. Program will exit.

So what's the problem?