Thanks guys.

The problem is solved. I copied cassandra and to my bin folder.
Then used "ant release " to generate my customized cassandra.jar in dist folder.
it worked.

To Aaron: I tried "ant artefacts", but it failed. is it because I am using Cassandra 0.7?
What's the difference between "ant artefacts" and "ant release"?

2011/8/6 aaron morton <>
Have a look at this file in the source repo

try using "ant artefacts" and look in the build/dist dir.

Aaron Morton
Freelance Cassandra Developer

On 7 Aug 2011, at 03:58, Alvin UW wrote:


I am a beginner.
I checked bin folder under myCassandra. There are only some classes without executable file.
after "ant release", I got the jar file from build folder.

2011/8/6 Jonathan Ellis <>
look at bin/cassandra, you can't just run it with "java -jar"

On Sat, Aug 6, 2011 at 10:43 AM, Alvin UW <> wrote:
> Hello,
> I set up a Cassandra project in Eclipse following
> Then, I made a few modifications on it to form a customised Cassandra.
> But I don't know how can I release this new Cassandra from Eclipse as a jar
> file to use in EC2.
> I tried "ant release" command in command line. It can successful build .jar
> file.
> Then I typed java -jar apache-cassandra-0.7.0-beta1-SNAPSHOT.jar
> "Error: Failed to load Main-Class manifest attribute from "
> I edited a MANIFEST.MF like:
> Manifest-Version: 1.0
> Ant-Version: Apache Ant 1.7.1
> Created-By: 16.3-b01 (Sun Microsystems Inc.)
> Implementation-Title: Cassandra
> Implementation-Version: 0.7.0-beta1-SNAPSHOT
> Implementation-Vendor: Apache
> Main-Class: org.apache.cassandra.thrift.CassandraDaemon
> and tried again. the error is like below:
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/thrift/transport/TTransportException
> Caused by: java.lang.ClassNotFoundException:
> org.apache.thrift.transport.TTransportException
>     at$
>     at Method)
>     at
>     at java.lang.ClassLoader.loadClass(
>     at sun.misc.Launcher$AppClassLoader.loadClass(
>     at java.lang.ClassLoader.loadClass(
>     at java.lang.ClassLoader.loadClassInternal(
> Could not find the main class: org.apache.cassandra.thrift.CassandraDaemon.
> Program will exit.
> So what's the problem?
> Thanks.
> Alvin

Jonathan Ellis
Project Chair, Apache Cassandra
co-founder of DataStax, the source for professional Cassandra support