cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jian Fang <jian.fang.subscr...@gmail.com>
Subject Re: Cassandra 0.6.8 snapshot problem?
Date Tue, 02 Aug 2011 14:08:23 GMT
We simply copy the snapshot data to another cluster to replace its data
directory. This cluster does not have any incoming traffic.

I haven't compared the md5 sum yet. Will try that.

Thanks,

John

On Thu, Jul 28, 2011 at 10:27 PM, Zhu Han <schumi.han@gmail.com> wrote:

>
>
> On Thu, Jul 28, 2011 at 10:47 PM, Jian Fang <jian.fang.subscribe@gmail.com
> > wrote:
>
>> Hi,
>>
>> We have an old production Cassandra 0.6.8 instance without replica, i.e.,
>> the replication factor is 1. Recently, we noticed that
>> the snapshot data we took from this instance are inconsistent with the
>> running instance data. For example, we took snapshot
>> in early July 2011. From the running instance, we got a record that was
>> created in March 2011, but on the snapshot copy, the
>> record with the same key was different and was created in January 2011.
>> Yesterday, we created another snapshot and reproduced
>> the problem. I just like to know if this is a known issue for Cassandra
>> 0.6.
>>
>
> Do you see any difference between the sstables of running instance and the
> snapshot?  You can use md5sum to compare them.
>
> How do you load the snapshot to another cluster?
>
>>
>> We are going to migrate to Cassandra 0.8, but we need to make sure this
>> will not be a problem in 0.8.
>>
>> Thanks in advance,
>>
>> John
>>
>>
>

Mime
View raw message