cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafael Almeida <>
Subject "Internal error processing get" during bootstrap
Date Tue, 26 Jul 2011 23:03:09 GMT

I'm evaluating cassandra for use in my system. I could add approximately 16 million items
using a single node. I'm using libcassandra (I can find my way through its code when I need
to) to connect to it and I already have some infrastructure for handling and adding those
items (I was using tokio cabinet before).

I couldn't find much documentation regarding how to make a cluster, but it seemed simple enough.
At cassandra server A ( I had seeds: "locahost". At server B ( I configured
seeds: "" and auto_bootstrap: true. Then I created a keyspace and a few column families
in it.

I imediately began to add items and to get all these "Internal error processing get". I found
it quite odd, I thought it had to do with the load I was putting in, seeing that a few small
tests had worked before. I spent quite some time debugging, when I finally decided to write
this e-mail. I wanted to double check stuff, so I ran nodetool to see if everything was right.
To my surprise, there was only one of the node available. It took a little while for the other
one to show up as Joining and then as Normal.

After I waited that period, I was able to insert items to the cluster with no error at all.
Is that expected behaviour? What is the recommended way to setup a cluster? Should it be done
manually. Setting up the machines, creating all keyspaces and colum families then checking
nodetool and waiting for it to get stable?

On a side note, sometimes I get "Default TException" (that seems to happen when the machine
is in a heavier load than usual), commonly retrying the read or insert right after works fine. 
Is that what's supposed to happen? Perhaps I should raise some timeout somewhere?

This is what ./bin/nodetool -h localhost ring reports me:

Address         DC          Rack        Status State   Load           
Owns    Token                                      

119105113551249187083945476614048008053     datacenter1 rack1       Up     Normal  3.43 GB        
65.90%  61078635599166706937511052402724559481    datacenter1 rack1       Up     Normal  1.77 GB         34.10% 

It's still adding stuff. I have no idea why B owns so many more keys than A.

I'm sorry if what I'm asking is trivial. But I have been having a hard time finding documentation.
I've found a lot of outdated stuff, which was frustrating. I hope you guys have the time to
help me out or -- if not -- I hope you can give me good reading material.

Thank you,

View raw message