On Fri, Jun 3, 2011 at 12:21 PM, David McNelis <dmcnelis@agentisenergy.com> wrote:
I want to make sure I'm not seeing things from a weird perspective.  I have two Cassandra instances where one is set to be the seed, with autobootstap disabled and its seed being 127.0.0.1.

The second instance has autobootstrap enabled and the seed IP set to the IP of the first node.

I start the first node, then the second, with no errors.  However, when I run:

bin/nodetool -h localhost ring

My output shows me only the local machine in my ring.  When I run:

bin/nodetool -h localhost join seedNodeIP

It tells me I'm already a part of the ring. 

My question is which is correct?  I thought, from the documentation, that both of my nodes would show up in the ring if I ran 'ring' in nodetool.

This is a new cluster.

--
David McNelis
Lead Software Engineer
Agentis Energy
www.agentisenergy.com
o: 630.359.6395
c: 219.384.5143

A Smart Grid technology company focused on helping consumers of energy control an often under-managed resource.



Do use 127.0.0.1 as a seed (except for single node test clusters) Use a route-able ip that other cluster nodes can use to reach that node.