cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David McNelis <>
Subject Setting up cluster and nodetool ring in 0.8.0
Date Fri, 03 Jun 2011 16:21:14 GMT
I want to make sure I'm not seeing things from a weird perspective.  I have
two Cassandra instances where one is set to be the seed, with autobootstap
disabled and its seed being

The second instance has autobootstrap enabled and the seed IP set to the IP
of the first node.

I start the first node, then the second, with no errors.  However, when I

bin/nodetool -h localhost ring

My output shows me only the local machine in my ring.  When I run:

bin/nodetool -h localhost join seedNodeIP

It tells me I'm already a part of the ring.

My question is which is correct?  I thought, from the documentation, that
both of my nodes would show up in the ring if I ran 'ring' in nodetool.

This is a new cluster.

*David McNelis*
Lead Software Engineer
Agentis Energy
o: 630.359.6395
c: 219.384.5143

*A Smart Grid technology company focused on helping consumers of energy
control an often under-managed resource.*

View raw message