How do you delete the data in the cli ? Is it a row delete e.g. del MyCF['my-key'];

What client are you using the insert the row the second time ? e.g. custom thrift wrapper or pycassa 

How is the second read done, via the cli ? 

Does the same test work when you only use your app ? 
 
Cassandra-cli will be using the current time as it's time stamp for the delete. If I had to guess what was happening it would be a problem with the timestamps your app is creating.

Thanks

-----------------
Aaron Morton
Freelance Cassandra Developer
@aaronmorton

On 12 May 2011, at 12:42, anuya joshi wrote:

Thanks aaron. here come the details:

1) Version: 0.7.4
2) Its a two node cluster with RF=2
3) It works perfectly after 1st get. Then I delete all the columns in a row. Finally, I try to insert into the same row with same row id. However, its not getting inserted programmatically.

Thanks,
Anuya

On Tue, May 3, 2011 at 2:03 AM, aaron morton <aaron@thelastpickle.com> wrote:
If your are still having problems can you say what version, how many nodes, what RF, what CL and if after inserting and failing on the first get it works on a subsequent get. 


Thanks
Aaron

On 3 May 2011, at 18:54, chovatia jaydeep wrote:

One small correction in my mail below. 
Second insertion time-stamp has to be greater than delete time-stamp in-order to retrieve the data.

Thank you,
Jaydeep

From: chovatia jaydeep <chovatia_jaydeep@yahoo.co.in>
To: "user@cassandra.apache.org" <user@cassandra.apache.org>
Sent: Monday, 2 May 2011 11:52 PM
Subject: Re: Unable to add columns to empty row in Column family: Cassandra

Hi Anuya,

> However, columns are not being inserted.

Do you mean to say that after insert operation you couldn't retrieve the same data? If so, then please check the time-stamp when you reinserted after delete operation. Your second insertion time-stamp has to be greater than the previous insertion.

Thank you,
Jaydeep

From: anuya joshi <anucjs@gmail.com>
To: user@cassandra.apache.org
Sent: Monday, 2 May 2011 11:34 PM
Subject: Re: Unable to add columns to empty row in Column family: Cassandra

Hello,

I am using Cassandra for my application.My Cassandra client uses Thrift APIs directly. The problem I am facing currently is as follows:

1) I added a row and columns in it dynamically via Thrift API Client
2) Next, I used command line client to delete row which actually deleted all the columns in it, leaving empty row with original row id.
3) Now, I am trying to add columns dynamically using client program into this empty row with same row key
    However, columns are not being inserted.
    But, when tried from command line client, it worked correctly.

Any pointer on this would be of great use

Thanks in  advance,

Regards,
Anuya