cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sameer Farooqui <>
Subject Questions about using MD5 encryption with SimpleAuthenticator
Date Mon, 16 May 2011 22:55:21 GMT
Hi all,

We are trying to use MD5 encrypted passwords. Quick question first - Is
SHA-2 supported yet? US-CERT of the U. S. Department of Homeland Security
has said that MD5 "should be considered cryptographically broken and
unsuitable for further use”, and SHA-2 family of hash functions is

The issue I'm seeing is that when I turn on MD5 encryption, I can't log into
the cluster from Cassandra-CLI (I get a login failure).

The file has been changed as so:


And I ran this python script to generate a MD5 hash:
ubuntu@darknet:~$ python
Python 2.6.6 (r266:84292, Sep 15 2010, 15:52:39)
[GCC 4.4.5] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from hashlib import md5
>>> p = "nosql"
>>> h = md5(p).hexdigest()
>>> print h

Then I updated the file with the new hashed password:

Also, the file is properly set so that jdoe has rw access
to the keyspace and CF:

But when I try to connect to the cluster now, I'm getting a login failure. I
have tried a few different ways of connecting:

Ran this from the Cassandra CLI:
[default@unknown] connect jdoe
Login failure. Did you specify 'keyspace', 'username' and 'password'?

Ran these from the Ubuntu CLI:
bin/cassandra-cli -h -p 9160 -u
jdoe -pw 9fa1b39e7eb877367213e6f7e37d0b01 -k MDR
Login failure. Did you specify 'keyspace', 'username' and 'password'?

bin/cassandra-cli -h -p 9160 -u
jdoe -pw '9fa1b39e7eb877367213e6f7e37d0b01' -k MDR
Login failure. Did you specify 'keyspace', 'username' and 'password'?

Hmm, what am I doing wrong?

- Sameer

View raw message