cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Naryshkin <>
Subject Re: Making a custom Cassandra RPM
Date Fri, 06 May 2011 14:56:43 GMT
Sorry that I did not get back to you on the issue. Your suggestion worked and I was able to
get the RPM to build. Unfortunately, it still does not work for me. I am getting the error
described in .

I tried Cassandra 0.8 beta 1 tag (the one that is known to have the bug), the trunk as it
was around mid-day (Eastern time) yesterday, the trunk this morning, and the 0.8 beta 2 tag.


----- Original Message -----
From: "Nick Bailey" <>
Sent: Wednesday, May 4, 2011 7:37:56 PM
Subject: Re: Making a custom Cassandra RPM

Your apache ant install is too old. The ant that comes with
rhel/centos 5.X isn't new enough to build cassandra. You will need to
install ant manually.

On Wed, May 4, 2011 at 2:01 PM, Konstantin  Naryshkin
<> wrote:
> I want to create a custom RPM of Cassandra (so I can deploy it
> pre-configured). There is an RPM in the source tree, but it does not contain
> any details of the setup required to create the RPM (what files should I
> have where). I have tried to run rpmbuild -bi on the spec file and I am
> getting the following error:
> /root/rpmbuild/BUILD/apache-cassandra-0.8.0-beta1-src/build.xml:187: name,
> file or resource attribute of typedef is undefined
> In case you were wondering what line 187 is, it is part of the
> maven-ant-tasks-init target and is:
> <typedef uri="antlib:org.apache.maven.artifact.ant"
> classpathref="maven-ant-tasks.classpath" />

View raw message