cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jonathan.co...@gmail.com
Subject Re: jsvc hangs shell
Date Wed, 11 May 2011 21:40:47 GMT
We use the Java Service Wrapper from Tanuki Software and are very happy  
with it. It's a lot more robust than jsvc.

http://wrapper.tanukisoftware.com/doc/english/download.jsp

The free community version will be enough in most cases.

Jon

On May 11, 2011 10:30pm, Anton Belyaev <anton.belyaev@gmail.com> wrote:
> Hello,



> I installed 0.7.5 to my Ubuntu 11.04 64 bit from package at

> deb http://www.apache.org/dist/cassandra/debian 07x main



> And I met really strange problem.

> Any shell command that requires Cassandra's jsvc command line (for

> example, "ps -ef", or "top" with cmdline args) - just hangs.

> Using STRACE I found out that commands hang during reading

> /proc//cmdline.

> I tried to "cat" the file - shell hung.



> I tried both OpenJDK and Sun JDK - the bug remains.

> I tried 0.6.13 on the same machine - works fine.

> I tried 0.7.5 on another machine (with older Ubuntu) - works fine.



> I believe this is not a Cassandra bug. But I am not sure where to ask

> help with the problem.

> Could you please advise what should I check to find out where is the  
> problem?



> Thanks.

> Anton.


Mime
View raw message