cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Ellis <jbel...@gmail.com>
Subject Re: JNA C library errors on OSX
Date Mon, 25 Apr 2011 14:05:37 GMT
Pretty sure this is b/c OS X doesn't support posix_fadvise.

Since you shouldn't be running OS X as a server OS in production
anyway, I wouldn't worry much. Cassandra will still work fine for
development w/o native methods.

On Mon, Apr 25, 2011 at 7:52 AM, John Lennard <john@gravitate.co.nz> wrote:
> Hi,
>
> I am currently testing the current 0.8 beta on my OSX development machine and when cassandra
is starting up i am seeing errors from the JNA code as below.
>
>
> john@balorama bin $ sudo -u cassandra ./cassandra -f
> Password:
>  INFO 00:04:18,013 Logging initialized
>  INFO 00:04:18,027 Heap size: 2126512128/2126512128
>  INFO 00:04:18,078 Unable to link C library. Native methods will be disabled.
>
> ...
>
> From here Cassandra continues to run, however, without native method support.
>
>
> I have tested running Cassandra as root, the logged in user and the cassandra user along
with the most recent JNA and a version compiled from trunk. I have also tried running cassandra
with out any of the start up scripts and still the same error, simple tests where by i have
removed the CLibrary class and code that causes the fault seem to allow the c library to be
linked.
>
> I am about to build a version from source to add in some stack traces where the error
is handled but was wondering if anyone else has seen this.
>
>
> Thanks
> John
>
>
>
>



-- 
Jonathan Ellis
Project Chair, Apache Cassandra
co-founder of DataStax, the source for professional Cassandra support
http://www.datastax.com

Mime
View raw message