cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Speirs <>
Subject Dropping & Creating Column Families Never Returns
Date Tue, 15 Feb 2011 21:46:27 GMT
Has anyone ever tried to drop a column family and/or create one and
have the command not return from the cli? I'm using 0.7.1 and I tried
to drop a column family and the command never returned. However, on
another node it showed it was gone. I Ctrl-C out of the command, then
issued a create for a column family of the same name, different
schema. That command never returned, but again in other host it showed
it was there. I went to describe and list this column family and got

[default@Logging] describe keyspace Logging;
Keyspace: Logging:
  Replication Strategy: org.apache.cassandra.locator.SimpleStrategy
    Replication Factor: 3
  Column Families:
    ColumnFamily: Messages
      Columns sorted by: org.apache.cassandra.db.marshal.UTF8Type
      Row cache size / save period: 0.0/0
      Key cache size / save period: 200000.0/14400
      Memtable thresholds: 0.5953125/127/60
      GC grace seconds: 864000
      Compaction min/max thresholds: 4/32
      Read repair chance: 1.0
      Built indexes: []
[default@Logging] list Messages;
Messages not found in current keyspace.

Any ideas?


View raw message