cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Ellis <jbel...@gmail.com>
Subject Re: Rows missing after new node bootstrapped
Date Sun, 14 Nov 2010 08:51:29 GMT
Are you using a version with working range scans?

On Sat, Nov 13, 2010 at 6:11 PM, Christian Decker
<decker.christian@gmail.com> wrote:
> Hi all,
>
> I'm having some doubts about the current state of my cluster. I started with
> one node, filled it with some 10 million rows, then flushed and compacted
> the node. Then I ran a small pig script that read an index and fetched the
> matching rows, no problem until this point. Now I add a new node with
> AutoBootStrap turned on, it all seems to work as it chooses a token to take
> over some of the first nodes responsibilities, it seems to transfer all the
> relevant data and everything looks fine. Now if I run the pig script again
> it'll produce many empty rows, which points me to believe that these rows
> were read from the new node which doesn't yet have the corresponding data.
> Now this puzzles me, since I thought the bootstrap would transfer the needed
> data, will this eventually return to give me no empty rows or have I done
> something terribly wrong?
>
> Regards,
> Chris
>



-- 
Jonathan Ellis
Project Chair, Apache Cassandra
co-founder of Riptano, the source for professional Cassandra support
http://riptano.com

Mime
View raw message