cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abdul Fattah Mahran <abdoo.mah...@gmail.com>
Subject cassandra.thrift error
Date Mon, 08 Nov 2010 12:27:50 GMT
Dear all,
       I am learning Cassandra these days, and I found that when I tried to
make "thrift --gen erl interface/cassandra.thrift"  I got the following
error
[Failure: PATH_TO_HOME_DIRECTORY/interface/cassandra.thrift:303] error:
identifier ONE is unqualified!

After some digging, I found that there is an error in cassandra.thrift file
in a lot of lines [303, 314, 336, 345 ..] that contains  "required
ConsistencyLevel consistency_level=ONE" and this is should be "required
ConsistencyLevel consistency_level=*ConsistencyLevel.ONE*", I changed it in
the rest places and now it worked fine.

I found that in the latest release from *Apache-Cassandra-0.6.6*, I wish
that helps in changing it to the right one.

Thanks
Best Regards,

Abd El-Fattah Mahran
Software Developer
Customer Adaptation Center, RMEA
Ericsson Egypt Ltd,

Mime
View raw message