cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Decker <decker.christ...@gmail.com>
Subject Rows missing after new node bootstrapped
Date Sun, 14 Nov 2010 00:11:46 GMT
Hi all,

I'm having some doubts about the current state of my cluster. I started with
one node, filled it with some 10 million rows, then flushed and compacted
the node. Then I ran a small pig script that read an index and fetched the
matching rows, no problem until this point. Now I add a new node with
AutoBootStrap turned on, it all seems to work as it chooses a token to take
over some of the first nodes responsibilities, it seems to transfer all the
relevant data and everything looks fine. Now if I run the pig script again
it'll produce many empty rows, which points me to believe that these rows
were read from the new node which doesn't yet have the corresponding data.
Now this puzzles me, since I thought the bootstrap would transfer the needed
data, will this eventually return to give me no empty rows or have I done
something terribly wrong?

Regards,
Chris

Mime
View raw message