cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stump.J.Xu / 徐隽 <stum...@gmail.com>
Subject Re: Rows missing after new node bootstrapped
Date Sun, 14 Nov 2010 04:01:21 GMT
你用的哪个版本? 我碰到了另外一种情况,还没找到解决办法。当Cassandra中插入了一批错误数据的时候,似乎数据的正常读取受到了干扰。
Which version? I ran into another situation, not to find a solution.
When Cassandra inserted a number of erroneous data, it seems the
normal data read by the interference.

Stump Xu


2010/11/14 Christian Decker <decker.christian@gmail.com>:
> Hi all,
>
> I'm having some doubts about the current state of my cluster. I started with
> one node, filled it with some 10 million rows, then flushed and compacted
> the node. Then I ran a small pig script that read an index and fetched the
> matching rows, no problem until this point. Now I add a new node with
> AutoBootStrap turned on, it all seems to work as it chooses a token to take
> over some of the first nodes responsibilities, it seems to transfer all the
> relevant data and everything looks fine. Now if I run the pig script again
> it'll produce many empty rows, which points me to believe that these rows
> were read from the new node which doesn't yet have the corresponding data.
> Now this puzzles me, since I thought the bootstrap would transfer the needed
> data, will this eventually return to give me no empty rows or have I done
> something terribly wrong?
>
> Regards,
> Chris
>



-- 
徐隽
Tel: 13818213223
Email: stumpxu@gmail.com
国家反计算机入侵和防病毒研究中心
信息网络安全公安部重点实验室
公安部第三研究所信息网络安全研发中心
上海辰星电子数据司法鉴定中心

Mime
View raw message