cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stu Hood <stuh...@gmail.com>
Subject Re: using SimpleAuthenticator is not working
Date Sun, 14 Nov 2010 00:27:46 GMT
Is the server logging anything during the failed authentication?


On Fri, Nov 12, 2010 at 8:07 PM, Alaa Zubaidi <alaa.zubaidi@pdf.com> wrote:

>  using SimpleAuthenticator is not working with me in beta 3
>
> I am doing the following:
>
> ·         In Cassandra.yaml Set
> authenticator: org.apache.cassandra.auth.SimpleAuthenticator
> ·         Add username and password to passwd.proprties
> ·         Add username to keyspace and column family permission in
> access.proprties
> ·         Add the path for passwd.proprties and access.proprties to
> Cassandra.bat
> set CASSANDRA_PARAMS=-Dcassandra -Dcassandra-foreground=yes
>
> -Dpasswd.properties=E:\Cassandra\Cass07b3\apache-cassandra-0.7.0-beta3\conf\passwd.properties
>
> -Daccess.properties=E:\Cassandra\Cass07b3\apache-cassandra-0.7.0-beta3\conf\access.properties
>
> ·         Use login() to login to Cassandra in the application:
> Map<String, String> creds = new HashMap<String, String>();
> creds.put("user1", "pwd1");
> AuthenticationRequest Auth = new  AuthenticationRequest(creds);
> _client.login(Auth);
>
> its giving me an error, with no message, and if I try to do any thing its
> giving me "I am not logged in" error.
> Is there any thing I am missing?
>
>
> Thanks,
> --
> Alaa Zubaidi
>

Mime
View raw message