cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Gilmore <wordsmith_...@yahoo.com>
Subject Re: Cassandra won't start Java Issue Snow Leopard
Date Wed, 24 Nov 2010 18:17:42 GMT
For what it's worth, I had similar errors on a Windows 7 laptop with 0.7.0 beta 3.  Thought
something must be wrong with my classpath, but an installation of 0.6.8 worked fine.

--- On Wed, 11/24/10, Jeremy Hanna <jeremy.hanna1234@gmail.com> wrote:

From: Jeremy Hanna <jeremy.hanna1234@gmail.com>
Subject: Re: Cassandra won't start Java Issue Snow Leopard
To: user@cassandra.apache.org
Date: Wednesday, November 24, 2010, 10:12 AM

I think it's just a classpath issue with os x.  I've had it do that for me as well, but it
runs just fine from IntelliJ IDEA.  I had thought my own system was just somehow messed up.
 I'll do some checking and try to respond to the thread again sometime today.
On Nov 24, 2010, at 12:08 PM, Alberto Velandia wrote:
Then I guess it has something to do with the latest update of snow leopard, what's weird is
that If i run the cassandra_helper cassandra with the cassandra ruby gem it works, perhaps
it actually has something to do with Thrift

On Nov 24, 2010, at 12:59 PM, Paul Targett wrote:
I get the same problem. I've re-installed a number of times with thrift and ensured all Java
versions correct.
Install on Ubuntu and Centos works fine from same download.
PT
On 24 Nov 2010, at 17:54, Alberto Velandia wrote:
I just was the email before hitting enter on compiling bjam, any ideas? I tried the ./cassandra
-f and It didn't work


On Nov 24, 2010, at 12:46 PM, André Fiedler wrote:
ups, forget my last mail... that´s wrong... it´s an cassandra failure... :/

2010/11/24 Norman Maurer <norman@apache.org>


Change in the bin Directory and run ./cassandra -f



Bye

Norman



2010/11/24, Alberto Velandia <betovelandia@gmail.com>:

> Hi I'm getting this error when i run bin/cassandra -f

>

> Exception in thread "main" java.lang.NoClassDefFoundError:

> org/apache/cassandra/thrift/CassandraDaemon

> Caused by: java.lang.ClassNotFoundException:

> org.apache.cassandra.thrift.CassandraDaemon

>       at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

>       at java.security.AccessController.doPrivileged(Native Method)

>       at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

>       at java.lang.ClassLoader.loadClass(ClassLoader.java:307)

>       at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

>       at java.lang.ClassLoader.loadClass(ClassLoader.java:248)

>

> which seems to be a Java version issue, I've updated my ~/.profile to the

> following:

>

> export

> PATH="/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/bin:/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH"

> [[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"  # This

> loads RVM into a shell session.

>

> but I'm still getting the same error, I've also set the environment variable

> JAVA_HOME but I don't know If I did it right.

>

> can anyone help me? thx

>

>

>










Mime
View raw message