cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alberto Velandia <>
Subject Cassandra won't start Java Issue Snow Leopard
Date Wed, 24 Nov 2010 17:41:10 GMT
Hi I'm getting this error when i run bin/cassandra -f

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/cassandra/thrift/CassandraDaemon
Caused by: java.lang.ClassNotFoundException: org.apache.cassandra.thrift.CassandraDaemon
	at Method)
	at java.lang.ClassLoader.loadClass(
	at sun.misc.Launcher$AppClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(

which seems to be a Java version issue, I've updated my ~/.profile to the following:

export PATH="/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/bin:/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:$PATH"
[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"  # This loads RVM
into a shell session.

but I'm still getting the same error, I've also set the environment variable JAVA_HOME but
I don't know If I did it right.

can anyone help me? thx

View raw message