cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Morton <aa...@thelastpickle.com>
Subject Re: error: identifier ONE is unqualified!
Date Thu, 21 Oct 2010 20:28:04 GMT
Look for  lib/thrift-rXXXXX.jar in the source. XXXX is the svn revision to use. 

http://wiki.apache.org/cassandra/InstallThrift

Not sure if all those steps still apply, but it's what I did last time I felt like feeling
some angst. 

Aaron


On 22 Oct, 2010,at 08:57 AM, J T <jt4websites@googlemail.com> wrote:

What is the latest version of Thrift that cassandra-trunk is is supposed to work with ?

I know Thrift 0.2.0 works, I'm using that on an existing cassandra 0.7 trunk install

I recently tried setting up another casandra node and just got the latest version of Thrift,
which is now at 0.6.0 but after getting thrift to build, which was as much of a pain as I
remember it being from my previous install, I am unable to generate the thrift cassandra bindings
- in my case i'm interested in the erlang bindings, but I get the same problem if I try producing
the python or java bindings.

The error that occurs is below:

gen-thrift-py:
     [echo] Generating Thrift Python code from /opt/cassandra-trunk-0.7.0/interface/cassandra.thrift
....
     [exec] 
     [exec] [FAILURE:/opt/cassandra-trunk-0.7.0/interface/cassandra.thrift:376] error:
identifier ONE is unqualified!
     [exec] Result: 1

Sure, I could go through each version of thrift backwards, to 0.2.0 but given how much hassle
I have building it each time I thought it worth asking you guys what the latest version you
use is ?

Jason
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
    • Unnamed multipart/related (inline, None, 0 bytes)
View raw message