cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Morton <aa...@thelastpickle.com>
Subject Re: Tried to add a new node but f*ed up
Date Thu, 21 Oct 2010 09:59:06 GMT
Check your tokens are correct using the algorithm discussed on this page 
http://wiki.apache.org/cassandra/Operations

If all ok run a node tool cleanup to remove any data the nodes are no longer responsible for.
(see section on bootstrapping in the link above)

Finally, the load *may* include tombstones if you've been deleting data. (I cannot remember
of the top of my head if it's included in this load)

Hope that helps
Aaron


On 21 Oct 2010, at 14:33, Mark <static.void.dev@gmail.com> wrote:

> I tried adding a new node and rebalanced the ring via nodetool move but ending up in
a weird state. Blew away all data from 2 nodes (out of 3) and manually set tokens but its
completely unbalanced.
> 
> [root@cassandra1 apache-cassandra]# bin/nodetool --host localhost --port 8080 ring
> Address       Status     Load          Range                                      Ring
>                                       130359389109719946695111037210971065868
> x.x.x.x.x Up         20 MB          0                                               
                                |<--|
> x.x.x.x.x Up         30.02 MB      56713727820156410577229101238628035242     |     
 |
> x.x.x.x.x Up         30.36 GB      130359389109719946695111037210971065868    |-->|
> 
> I tried running nodetool repair but that doesn't seem to accomplish much. What should
I do??? Thanks!
> 

Mime
View raw message