cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gurpreet Singh <gurpreet.si...@gmail.com>
Subject Re: Bootstrapping stays stuck
Date Tue, 14 Sep 2010 17:41:00 GMT
I tried this again, it happenned yet again.
This time while the transfer messages seemed tobe in order, i also noticed
that the source logs talk about having 9 dropped messages in the last 1000
ms. The only activity on the whole cluster is this bootstrapping, there is
no read/write traffic going on.

/G

On Tue, Sep 14, 2010 at 10:05 AM, Gurpreet Singh
<gurpreet.singh@gmail.com>wrote:

> I am using cassandra 0.6.5.
>
>
> On Tue, Sep 14, 2010 at 9:16 AM, Gurpreet Singh <gurpreet.singh@gmail.com>wrote:
>
>> Hi,
>> I have a cassandra cluster of 4 machines, and I am trying to bootstrap 2
>> more machines, one at a time.
>> For both these machines, the bootstrapping stays stuck after the streaming
>> is done.
>>
>> When the nodes come up for bootstrapping, I see all the relevant messages
>> about getting a new token, assuming load from a particular host. I see a
>> couple of nodes anticompacting data to send, and at a later point the node
>> that is bootstrapping prints the right streaming mesgs. However, once the
>> streaming is over, the node just doesnt do anything. Previously while
>> bootstrapping, I have seen that after the streaming is done, the node
>> restarts and becomes part of the ring by itself. I dont see this behaviour
>> with both the nodes I tried today.
>> I even restarted all the nodes in the cluster, and tried bootstrapping one
>> of the nodes again, but it again was stuck after streaming. It seems to have
>> copied the relevant load as well.
>> Any ideas as to what could be going on here?
>>
>> /G
>>
>
>

Mime
View raw message