cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Morton <>
Subject Re: Schema Migration Failed
Date Thu, 30 Sep 2010 23:37:32 GMT
OK, turns out the sky was not falling :)

driftx helped me on IRC, we added the node tokens to the yaml file then deleted the entire
system directory, restarted and it worked. 

Guess I need to go back and read to
understand schema propagation. 


On 01 Oct, 2010,at 11:37 AM, Aaron Morton <> wrote:

Upgrading from 0.7 nightly for 31/08 to beta 2. 

This one seems serious, schema migration is failing. I'm dead in the water here, so any quick
ideas appreciated. 

Have done an import schema on one node, and also tried system_add_keyspace on the same node.
It's showing the Keyspace1 and my keyspace. But am getting these errors on the other nodes...

ERROR [READ_STAGE:19] 2010-10-01 11:31:57,872 (line 88) Fatal
exception in thread Thread[READ_STAGE:19,5,main]
java.lang.ClassCastException: org.apache.avro.util.Utf8 cannot be cast to java.lang.Double
        at org.apache.cassandra.config.avro.CfDef.put(
        at org.apache.avro.generic.GenericDatumReader.setField(
        at org.apache.avro.genericGenericDatumReader.readRecord(
        at org.apache.avro.generic.GenericDatumReader.readArray(
        at org.apache.avro.generic.GenericDatumReader.readRecord(
        at org.apache.avro.generic.GenericDatumReader.readRecord(
        at org.apache.avro.generic.GenericDatumReader.readRecord(
        at org.apache.cassandra.db.migrationMigration.deserialize(
        at org.apache.cassandra.db.DefinitionsUpdateResponseVerbHandler.doVerb(
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
        at java.util.concurrent.ThreadPoolExecutor$

And they are not showing the keyspace in JMX. So things are way out of wack.

is it correct to see avro in the call stack ? 


  • Unnamed multipart/alternative (inline, None, 0 bytes)
    • Unnamed multipart/related (inline, None, 0 bytes)
View raw message