cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruben de Laat <ru...@logic-labs.nl>
Subject Calls block when using Thrift API
Date Fri, 27 Aug 2010 15:13:43 GMT
Hi,

I am new to cassandra, so maybe I am missing something obvious...
Version: Latest nightly build (2010-08-23_13-57-40), but same results
with 0.7.0b1

Server code (default configuration file):

System.setProperty("cassandra.config", "conf/cassandra.yaml");
EmbeddedCassandraService embeddedCassandraService = new
EmbeddedCassandraService();
embeddedCassandraService.init();

Client code:

Socket socket = new Socket("127.0.0.1", 9160);
TSocket transport = new TSocket(socket);
TBinaryProtocol tBinaryProtocol = new TBinaryProtocol(transport);
Client client = new Client(tBinaryProtocol);
System.out.println(client.describe_cluster_name());

The problem is that it hangs/blocks on the
"client.describe_cluster_name()" call, actually it hangs on any call I
have tried.
I was first trying with the Pelops client, but that one is using the
Thrift API as well, so this is narrowed down.

I have already tried multiple different combination of creating the
client (different transports).
I have also tried with "thrift_framed_transport_size_in_mb: 0"
disabling framed transports.

Starting the client without a running server gives a proper
"Connection refused", so some sort of connection is definitely made.

Thanks and Kind regards,
Ruben

Mime
View raw message