cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Harrison <dave.l.harri...@gmail.com>
Subject Re: Row deletion and get_range_slices (cassandra 0.6.1)
Date Fri, 23 Apr 2010 03:24:30 GMT
Do those tombstone-d keys ever get purged completely ?  I've tried
shortening the GCGraceSeconds right down but they still don't get
cleaned up.

On 23 April 2010 08:57, Jonathan Ellis <jbellis@gmail.com> wrote:
> http://wiki.apache.org/cassandra/FAQ#range_ghosts
>
> On Thu, Apr 22, 2010 at 5:29 PM, Carlos Sanchez
> <carlos.sanchez@riskmetrics.com> wrote:
>> I have a curious question..
>>
>> I am doing some testing where I insert 500 rows to a super column family and then
delete one row, I make sure the row was indeed deleted (NotFoundException in the get call)
and then I ran a get_range_slices and the row indeed returned. The shutdown Cassandra and
restarted it. I repeated the test (with inserting the rows) and even though I get the NotFoundException
for that row, the get_rance_slices still returns it.  Is this the expected behavior? How
long should I wait before I don't see the row in the get_range_slices? Do I have to force
a flush or change consistency level?
>>
>> Thanks,
>>
>> Carlos
>>
>> This email message and any attachments are for the sole use of the intended recipients
and may contain proprietary and/or confidential information which may be privileged or otherwise
protected from disclosure. Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not an intended recipient, please contact the sender by reply email and destroy
the original message and any copies of the message as well as any attachments to the original
message.
>>
>

Mime
View raw message