cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lee Parker <...@socialagency.com>
Subject Re: batch_mutate silently failing
Date Tue, 13 Apr 2010 21:24:59 GMT
nevermind.  I figured out what the problem was.  I was not putting the
column inside a ColumnOrSuperColumn container.

Lee Parker
lee@spredfast.com

[image: Spredfast]
On Tue, Apr 13, 2010 at 4:19 PM, Lee Parker <lee@socialagency.com> wrote:

> I upgraded my dev environment to 0.6.0 today in expectation of upgrading
> our prod environment soon.  I am trying to rewrite some of our code to use
> batch_mutate with the Thrift PHP library directly.  I'm not getting any
> result back, not even an exception or failure message, but the data is never
> showing up in the single node cassandra setup.  Here is a dump of my
> mutation map:
>
> array(1) {
>   ["testkey"]=>
>   array(1) {
>     ["StreamItems"]=>
>     array(2) {
>       [0]=>
>       object(cassandra_Mutation)#156 (2) {
>         ["column_or_supercolumn"]=>
>         object(cassandra_Column)#157 (3) {
>           ["name"]=>
>           string(4) "test"
>           ["value"]=>
>           string(14) "this is a test"
>           ["timestamp"]=>
>           float(1271193181943.1)
>         }
>         ["deletion"]=>
>         NULL
>       }
>       [1]=>
>       object(cassandra_Mutation)#158 (2) {
>         ["column_or_supercolumn"]=>
>         object(cassandra_Column)#159 (3) {
>           ["name"]=>
>           string(5) "test2"
>           ["value"]=>
>           string(19) "Another test column"
>           ["timestamp"]=>
>           float(1271193181943.2)
>         }
>         ["deletion"]=>
>         NULL
>       }
>     }
>   }
> }
>
> When I pass this into client->batch_mutate, nothing seems to happen.  Any
> ideas about what could be going on?  I have been able to insert data using
> cassandra-cli without issue.
>
> Lee Parker
> lee@spredfast.com
>
> [image: Spredfast]
>

Mime
View raw message