cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Gallamore <>
Subject Re: Net::Cassandra::Easy deletion failed
Date Tue, 06 Apr 2010 20:24:45 GMT
Thanks for the reply. The newest version of the module I see on CPAN is 
0.08b. I actually had 0.07 installed and am using 0.6beta3 for 
cassandra. Is there somewhere else I should look for the 0.09 version of 
the module? I'll also upgrade to the release candidate version of 
Cassandra and see if that helps.
On 04/06/2010 01:14 PM, Ted Zlatanov wrote:
> On Tue, 06 Apr 2010 11:07:03 -0700 Mike Gallamore<>
> MG>  Seems to be internal to java/cassandra itself.
> MG>  I have some tests and I want to make sure that I have a "clean slate"
> MG>  each time I run the test. Clean as far as my code cares is that
> MG>  "value" is not defined. I'm running  "bin/cassandra -f" with the
> MG>  default install/options. So at the beginning of my test I run:
> Mike, you can submit bugs and questions directly to me, here, or through
> (the CPAN bug tracker).  It's a good idea to test an
> operation from the CLI that comes with Cassandra to make sure the
> problem is not with the Net::Cassandra::Easy module.
> Also, if you set $Net::Cassandra::Easy::DEBUG to 1, you'll see the
> actual Thrift objects that get constructed.  In this case (N::C::Easy
> 0.08) I was constructing a super_column parameter which was wrong.
> MG>  $rc = $c->mutate([$key], family =>  'Standard1', deletions =>  { byname
=>  ['value']});
> ...
> MG>  Anyone have any ideas what I'm doing wrong? The value field is just a
> MG>  json encoded digit so something like ("30") not a real supercolumn but
> MG>  the Net::Cassandra::Easy docs didn't have any examples of removing a
> MG>  non supercolumns data. Really what I'd like to do is delete the whole
> MG>  row, but again I didn't find any examples of how to do this.
> It's a bug in N::C::Easy.  I fixed it in 0.09 so it will work properly with:
> $rc = $c->mutate([$key], family =>  'Standard1', deletions =>  { standard =>
 1, byname =>  ['column1', 'column2']});
> AFAIK I can't specify "delete all columns in a non-super CF" using
> Deletions so "byname" is required (I end up filling the column_names
> field in the predicate).  OTOH I can just delete a SuperColumn so the
> above is possible in a super CF.
> The docs and tests were updated as well.  Let me know if you have
> problems; it worked for me.  In the next release I'll update
> to work with non-super CFs as well.  Sorry for the inconvenience.
> Thanks
> Ted

View raw message