cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raymond Wilson" <>
Subject RE: Frustrations installing Cassandra on Windows
Date Wed, 24 Mar 2010 22:19:13 GMT
I tried removing the ivy folder in \users\rwilson and then just running ant in the Cassandra


This appeared to be working until it complained about the same issue with resolving dependencies


I tried deleting the ivy jar file I downloaded via Google and rant Ant again. This time it
complained about not being able to download the ivy jar.




From: Christopher Brind [] 
Sent: Wednesday, 24 March 2010 10:26 p.m.
Subject: Re: Frustrations installing Cassandra on Windows


I don't know if there's some difference between building on Mac and Windows, but I just tried
building from the latest git repo and that was fine.  


I also downloaded and built the 0.6 src tar ball from apache-cassandra-0.6.0-beta3-src.tar.gz
 and that was fine too.


Now you know you have Java and Ant setup properly, try removing your .ivy2 folder ( C:\Users\rwilson\.ivy2
)  and just running ant (don't specify a target).  The build script seems to do all the retrieve
stuff, so you shouldn't need to do that manually.







On 24 March 2010 02:49, Raymond Wilson <> wrote:


I've been looking at using Cassandra as a distributed database for use
in our server software, which runs on Windows.

This afternoon I've been trying to get Cassandra installed and running.
Actually installing Cassandra was pretty easy, at least in the steps of
"Download it, setup CASSANDRA_HOME and fiddle with the storage
configuration file", however getting it to run has not been so easy.
Admittedly, this is my first ever attempt at installing and running this
system, so I'm a sort of monkey tester here ;)

Here's a brief run-down of the issues I ran into trying out Cassandra
6.0 Beta 3, after installing Java 6 u18 and Cassandra itself (following
the instructions in,
which may be out of date)

1. On running Cassandra, I get messages about the system not being able
to locate a path. Eventually figure out that JAVA_HOME needs to point to
a location in the [Program files]\Java folder, rather that location
itself (newbie error)
2. After configuring JAVA_HOME correctly, I get errors that the new
logging jar can't be found. I realise I skipped the 'Ant ivy-retrieve'
step in the instructions. So I download and install Ant, configure
ANT_HOME and run it.
3. I then run Ant ivy-retrieve. Oops, Tools.jar is not present. After
some Googling I determine that I need the JAVA JDK, rather than the JRE
to run it. (If this is a BETA, why does it need the JDK, surely the JRE
alone is sufficient?) I then download and install JDK 6v18 and update my
4. I then run Ant ivy-retrieve again. It starts running (great), then
fails with a generic error trying to get the ivy-2.1.0.jar file. I
copied the URL into Google which promptly downloaded it, so I'm not sure
what's wrong there. I copied the ivy-2.1.0.jar file into the build
folder and tried again
5. I then run Ant ivy-retrieve again, Success (sort of). The ant job
complains it can't get the file, then notices it's there after all and
proceeds to start building. That fails horribly with many error messages
in the command window.
6. I ran it again and captured the output (attached to the email). This
explains that lots of things couldn't be resolved.

Does anyone have a step-by-step, soup to nuts, from ground zero, list of
instructions to get Cassandra installed and running on a clean windows

As a suggestion, is it worth considering producing Cassandra builds that
contain all the peripheral bits and pieces it relies on (essentially
running the 'ant ivy-retrieve' command and bundling up the results as a
single download/install) so that clueless newbie users like me have a
better chance getting this running?



View raw message