cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sunil Khedar <>
Subject Re: Cassandra with static IP address on EC2 instance: org.apache.thrift.transport.TTransportException
Date Wed, 09 Dec 2009 09:57:00 GMT
Hey Simon,

9160 port is already authorized. While debugging I executed ifconfig
command, but the output was not having "eth1" details.

eth0      Link encap:Ethernet  HWaddr 11:31:3B:04:E2:13
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::1131:3bff:fe04:e213/64 Scope:Link
          RX packets:144913 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97374 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:130499932 (124.4 MiB)  TX bytes:13480650 (12.8 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1680 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1680 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:180916 (176.6 KiB)  TX bytes:180916 (176.6 KiB)

Do you think it can be a reason?


On Tue, Dec 8, 2009 at 8:46 PM, Simon Smith <> wrote:

> Do you have your Amazon security policy set to allow that port?  If
> you were accessing internally before, the internal security policy may
> have allowed that traffic, but the default external one doesn't (at
> least that is how it worked for my account).
> On Tue, Dec 8, 2009 at 10:09 AM, Sunil Khedar <>
> wrote:
> > Hi All,
> > I tried using public IP address of my EC2 instance for ThriftAddress, but
> > getting following error:
> > org.apache.thrift.transport.TTransportException: Could not create
> > ServerSocket on address /

View raw message