cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Shuler <mich...@pbandjelly.org>
Subject Re: Issue with this mornings upgrade of Staging DataStax Enterprise
Date Thu, 07 Apr 2016 13:47:58 GMT
This mailing list is for discussing the development of Apache Cassandra.
Either talk to your support folks at DataStax or try the user@ list for
help installing (which is probably also inappropriate for DSE).

FWIW, this is a simple user issue with multiple versions of the same
software in apt repositories and is documented in the DSE docs.

http://docs.datastax.com/en/datastax_enterprise/4.8/datastax_enterprise/install/installPrevious.html

-- 
Kind regards,
Michael
On 04/07/2016 07:34 AM, Ken Schell wrote:
> Jeff,
> 
> When you get in this morning can you come by and see me. I tried to
> upgrade node 01 in staging 10.10.160.42 and received the following
> issue. I’m going ahead and opening a DataStax Support ticket and see
> what they suggest.
> 
> From my screen:
> 
> root@stga-cass01:/var/log/cassandra# apt-get install dse-full Reading
> package lists... Done Building dependency tree Reading state
> information... Done Some packages could not be installed. This may
> mean that you have requested an impossible situation or if you are
> using the unstable distribution that some required packages have not
> yet been created or been moved out of Incoming. The following
> information may help to resolve the situation:
> 
> The following packages have unmet dependencies: dse-full : Depends:
> dse (= 4.8.6-1) but 4.8.1-1 is to be installed Depends: dse-hive (=
> 4.8.6-1) but it is not going to be installed Depends: dse-pig (=
> 4.8.6-1) but it is not going to be installed Depends: dse-demos (=
> 4.8.6-1) but it is not going to be installed E: Unable to correct
> problems, you have held broken packages. 
> root@stga-cass01:/var/log/cassandra# apt-get install dse-full Reading
> package lists... Done Building dependency tree Reading state
> information... Done Some packages could not be installed. This may
> mean that you have requested an impossible situation or if you are
> using the unstable distribution that some required packages have not
> yet been created or been moved out of Incoming. The following
> information may help to resolve the situation:
> 
> The following packages have unmet dependencies: dse-full : Depends:
> dse (= 4.8.6-1) but 4.8.1-1 is to be installed Depends: dse-hive (=
> 4.8.6-1) but it is not going to be installed Depends: dse-pig (=
> 4.8.6-1) but it is not going to be installed Depends: dse-demos (=
> 4.8.6-1) but it is not going to be installed E: Unable to correct
> problems, you have held broken packages. 
> root@stga-cass01:/var/log/cassandra# dse -v 4.8.1
> 
> The first step in the upgrade process is to run apt-get update. Which
> looked good to me.
> 
> From My Screen:
> 
> root@stga-cass01:/var/log/cassandra# apt-get update Ign
> http://apt.newrelic.com newrelic InRelease Hit
> http://apt.newrelic.com newrelic Release.gpg Hit
> http://apt.newrelic.com newrelic Release Hit http://apt.newrelic.com
> newrelic/non-free amd64 Packages Hit http://apt.newrelic.com
> newrelic/non-free i386 Packages Ign http://apt.newrelic.com
> newrelic/non-free Translation-en_US Ign http://apt.newrelic.com
> newrelic/non-free Translation-en Ign
> http://nova.clouds.archive.ubuntu.com trusty InRelease Hit
> http://ppa.launchpad.net trusty InRelease Get:1
> http://security.ubuntu.com trusty-security InRelease [65.9 kB] Get:2
> http://nova.clouds.archive.ubuntu.com trusty-updates InRelease [65.9
> kB] Ign http://ppa.launchpad.net trusty InRelease Hit
> http://nova.clouds.archive.ubuntu.com trusty Release.gpg Hit
> http://ppa.launchpad.net trusty/main amd64 Packages Get:3
> http://nova.clouds.archive.ubuntu.com trusty-updates/main Sources
> [271 kB] Hit http://ppa.launchpad.net trusty/main i386 Packages Hit
> http://ppa.launchpad.net trusty/main Translation-en Get:4
> http://security.ubuntu.com trusty-security/main Sources [110 kB] 
> Get:5 http://nova.clouds.archive.ubuntu.com trusty-updates/universe
> Sources [152 kB] Hit http://ppa.launchpad.net trusty Release.gpg 
> Get:6 http://nova.clouds.archive.ubuntu.com trusty-updates/main amd64
> Packages [754 kB] Hit http://ppa.launchpad.net trusty Release Hit
> http://ppa.launchpad.net trusty/main amd64 Packages Hit
> http://ppa.launchpad.net trusty/main i386 Packages Get:7
> http://security.ubuntu.com trusty-security/universe Sources [35.2
> kB] Hit http://ppa.launchpad.net trusty/main Translation-en Get:8
> http://nova.clouds.archive.ubuntu.com trusty-updates/universe amd64
> Packages [357 kB] Get:9 http://security.ubuntu.com
> trusty-security/main amd64 Packages [455 kB] Get:10
> http://nova.clouds.archive.ubuntu.com trusty-updates/main i386
> Packages [720 kB] Get:11 http://nova.clouds.archive.ubuntu.com
> trusty-updates/universe i386 Packages [359 kB] Get:12
> http://nova.clouds.archive.ubuntu.com trusty-updates/main
> Translation-en [378 kB] Get:13 http://nova.clouds.archive.ubuntu.com
> trusty-updates/universe Translation-en [187 kB] Hit
> http://nova.clouds.archive.ubuntu.com trusty Release Hit
> http://nova.clouds.archive.ubuntu.com trusty/main Sources Hit
> http://nova.clouds.archive.ubuntu.com trusty/universe Sources Hit
> http://nova.clouds.archive.ubuntu.com trusty/main amd64 Packages Hit
> http://nova.clouds.archive.ubuntu.com trusty/universe amd64 Packages 
> Hit http://nova.clouds.archive.ubuntu.com trusty/main i386 Packages 
> Get:14 http://security.ubuntu.com trusty-security/universe amd64
> Packages [126 kB] Hit http://nova.clouds.archive.ubuntu.com
> trusty/universe i386 Packages Hit
> http://nova.clouds.archive.ubuntu.com trusty/main Translation-en 
> Get:15 http://security.ubuntu.com trusty-security/main i386 Packages
> [429 kB] Hit http://nova.clouds.archive.ubuntu.com trusty/universe
> Translation-en Ign http://nova.clouds.archive.ubuntu.com trusty/main
> Translation-en_US Ign http://nova.clouds.archive.ubuntu.com
> trusty/universe Translation-en_US Get:16 http://security.ubuntu.com
> trusty-security/universe i386 Packages [126 kB] Hit
> http://security.ubuntu.com trusty-security/main Translation-en Hit
> http://security.ubuntu.com trusty-security/universe Translation-en 
> Ign http://debian.datastax.com stable InRelease Hit
> http://debian.datastax.com stable Release.gpg Hit
> http://debian.datastax.com stable Release Hit
> http://debian.datastax.com stable/main amd64 Packages Hit
> http://debian.datastax.com stable/main i386 Packages Ign
> http://debian.datastax.com stable/main Translation-en_US Ign
> http://debian.datastax.com stable/main Translation-en Fetched 4,593
> kB in 9s (498 kB/s) Reading package lists... Done
> 


Mime
View raw message