cassandra-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonas Borgström <>
Subject Re: [VOTE] Release Apache Cassandra 1.0.3
Date Mon, 14 Nov 2011 13:16:41 GMT
On 2011-11-14 13:08 , Radim Kolar wrote:
> I'm not sure why hints are not working for you. You might have hit some
> other issue. Some suggestions:
> 1. Verify that HintsColumnFamily actually contains some data with
> cassandra-cli and "list HintsColumnFamily"
> yes
>> 2. Try restarting the node containing the hints to check if that gets
>> your hints delivered (gossip state related issue?).
> INFO [HintedHandoff:1] 2011-11-14 12:35:15,557
> (line 334) Finished hinted handoff of 0 rows to endpoint /***99.40
> Worked. This is improvement. at least node tried to deliver hints. So
> conclusion was that keeping gossip state still has some issues?
> 3. but hints table is not empty after that. majority of hints
> disappeared but this was left in table. Take a look at it.

I suspect these partial/invalid hints are left over from a failed hints 
delivery from before you upgraded to 1.0.3 and not something created by 
Try to clear HintsColumnFamily (by removing the sstables for example) 
first and then see if you still can reproduce this issue afterwards.

/ Jonas

View raw message