cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joel Knighton (JIRA)" <>
Subject [jira] [Created] (CASSANDRA-13978) dtest failure in cqlsh_tests/ due to deprecation warning
Date Fri, 27 Oct 2017 17:22:00 GMT
Joel Knighton created CASSANDRA-13978:

             Summary: dtest failure in cqlsh_tests/
due to deprecation warning
                 Key: CASSANDRA-13978
             Project: Cassandra
          Issue Type: Test
          Components: Testing
            Reporter: Joel Knighton
            Priority: Trivial

The dtest {{cqlsh_tests/}} fails on all branches
with pep8 package version 1.7.1. The pep8 package has been deprecated and renamed pycodestyle.

FAIL: test_pep8_compliance (cqlsh_tests.cqlsh_tests.TestCqlsh)
Traceback (most recent call last):
  File "/home/jkni/projects/cassandra-dtest/tools/", line 48, in wrapped
  File "/home/jkni/projects/cassandra-dtest/cqlsh_tests/", line 68, in test_pep8_compliance
    self.assertEqual(len(stderr), 0, stderr)
AssertionError: /home/jkni/projects/cassandra-dtest/venv/lib/python2.7/site-packages/

pep8 has been renamed to pycodestyle (GitHub issue #466)
Use of the pep8 tool will be removed in a future release.
Please install and use `pycodestyle` instead.

$ pip install pycodestyle
$ pycodestyle ...


We should update this dependency from pep8 to pycodestyle. With this change, several new errors
are thrown. I don't know if these are new checks that we should choose to ignore, false positives
due to new behaviors, or false negatives that are now successfully caught. If they were previously
false negatives, we'll need to fix these in cqlsh on some branches.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message