cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akshay Jindal (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CASSANDRA-13811) Unable to find table <keyspace name>.<tablename> at maybeLoadschemainfo (StressProfile.java)
Date Sun, 27 Aug 2017 21:54:02 GMT
Akshay Jindal created CASSANDRA-13811:
-----------------------------------------

             Summary: Unable to find table <keyspace name>.<tablename> at maybeLoadschemainfo
(StressProfile.java)
                 Key: CASSANDRA-13811
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-13811
             Project: Cassandra
          Issue Type: Bug
          Components: Stress
         Environment: 3 node cluster
Node 1 --> 172.27.21.16(Seed Node)
Node 2 --> 172.27.21.18
Node 3 --> 172.27.21.19

*cassandra.yaml paramters for all the nodes:-*
1) seeds: "172.27.21.16"
2) write_request_timeout_in_ms: 5000
3) listen_address: 172.27.21.1(6,8,9
4) rpc_address: 172.27.21.1(6,8,9)

            Reporter: Akshay Jindal
             Fix For: 3.10
         Attachments: code.yaml, stress-script.sh

* Please find attached my .yaml and .sh file.
* Now the problem is if I run this the first time, just after firing up cassandra, it is working
fine, but when I again run this query, it is giving the following error:-

*Unable to find prutorStress3node.code*
at org.apache.cassandra.stress.StressProfile.maybeLoadSchemaInfo(StressProfile.java:306)
	at org.apache.cassandra.stress.StressProfile.maybeCreateSchema(StressProfile.java:273)
	at org.apache.cassandra.stress.StressProfile.newGenerator(StressProfile.java:676)
	at org.apache.cassandra.stress.StressProfile.printSettings(StressProfile.java:129)
	at org.apache.cassandra.stress.settings.StressSettings.printSettings(StressSettings.java:383)
	at org.apache.cassandra.stress.Stress.run(Stress.java:95)
	at org.apache.cassandra.stress.Stress.main(Stress.java:62)

In the file [https://insight.io/github.com/apache/cassandra/blob/trunk/tools/stress/src/org/apache/cassandra/stress/settings/StressSettings.java?line=121]
,I saw that table metadata is being populated to NULL. I tried to make sense of the stack
trace, but was not able to make anything of it. Please give me some directions as to what
might have gone wrong?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message