cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rajasekhar (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CASSANDRA-13792) unable to connect apache-cassandra-3.11.0 after place 4.2.2 JNA jar
Date Thu, 24 Aug 2017 06:41:00 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-13792?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

rajasekhar updated CASSANDRA-13792:
-----------------------------------
    Description: 
After apply work around below solution, installled the pache-cassandra-3.11 but i am not connect
server status and cqlsh. please find attached log for more information  and let us know the
instatllion completed successfully

"Jeff Jirsa resolved CASSANDRA-13791.
------------------------------------
    Resolution: Duplicate

This was caused (and resolved) by CASSANDRA-13072 , where JNA was upgraded to {{4.4.0}}. That
4.4.0 JNA library was linked against a different version of glibc ( {{GLIBC_2.14}} ), which
causes this error. This is fixed in {{3.11.1}}, but you can work around the issue by downloading
the 4.2.2 JNA jar from [here|https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_apache_cassandra_raw_00a777ec8ab701b843172e23a6cbdc4d6cf48f8d_lib_jna-2D4.2.2.jar&d=DwICaQ&c=eIGjsITfXP_y-DLLX0uEHXJvU8nOHrUK8IrwNKOtkVU&r=zSydaPm_PKES-H2mB46-9X-iWMDIIymvQCfY02eRW-Q&m=cSmoTlLQJTt32Gb257uuaz6_WHE6UeXOV5XjO7GTcxk&s=yieYJ2V_ND3saGBjGH3O-DEwQdfkA44B9yBqtjIU8bE&e=
] and placing it into the classpath ({{lib/}}), removing {{jna-4.4.0.jar}} in the process.


> unable to install apache-cassandra-3.11.0 in linux  box
> -------------------------------------------------------
"

[cassdb@alsc_dev_db bin]$ nodetool status
-bash: nodetool: command not found
[cassdb@alsc_dev_db bin]$ pwd
/u01/Cassandra_home/apache-cassandra-3.11.0/bin
[cassdb@alsc_dev_db bin]$ sh /u01/Cassandra_home/apache-cassandra-3.11.0/bin/cqlsh
No appropriate python interpreter found.
[cassdb@alsc_dev_db bin]$ service cassandra status


  was:
After apply work around below solution, installled the pache-cassandra-3.11 but i am not connect
server status and cqlsh. please find log for more information  and let us know the instatllion
completed successfully

[cassdb@alsc_dev_db bin]$ nodetool status
-bash: nodetool: command not found
[cassdb@alsc_dev_db bin]$ pwd
/u01/Cassandra_home/apache-cassandra-3.11.0/bin
[cassdb@alsc_dev_db bin]$ sh /u01/Cassandra_home/apache-cassandra-3.11.0/bin/cqlsh
No appropriate python interpreter found.
[cassdb@alsc_dev_db bin]$ service cassandra status



> unable to connect apache-cassandra-3.11.0 after place 4.2.2 JNA jar 
> --------------------------------------------------------------------
>
>                 Key: CASSANDRA-13792
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-13792
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Configuration
>         Environment: Linux
>            Reporter: rajasekhar
>             Fix For: 3.11.0
>
>         Attachments: log_cassdb.txt
>
>
> After apply work around below solution, installled the pache-cassandra-3.11 but i am
not connect server status and cqlsh. please find attached log for more information  and let
us know the instatllion completed successfully
> "Jeff Jirsa resolved CASSANDRA-13791.
> ------------------------------------
>     Resolution: Duplicate
> This was caused (and resolved) by CASSANDRA-13072 , where JNA was upgraded to {{4.4.0}}.
That 4.4.0 JNA library was linked against a different version of glibc ( {{GLIBC_2.14}} ),
which causes this error. This is fixed in {{3.11.1}}, but you can work around the issue by
downloading the 4.2.2 JNA jar from [here|https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_apache_cassandra_raw_00a777ec8ab701b843172e23a6cbdc4d6cf48f8d_lib_jna-2D4.2.2.jar&d=DwICaQ&c=eIGjsITfXP_y-DLLX0uEHXJvU8nOHrUK8IrwNKOtkVU&r=zSydaPm_PKES-H2mB46-9X-iWMDIIymvQCfY02eRW-Q&m=cSmoTlLQJTt32Gb257uuaz6_WHE6UeXOV5XjO7GTcxk&s=yieYJ2V_ND3saGBjGH3O-DEwQdfkA44B9yBqtjIU8bE&e=
] and placing it into the classpath ({{lib/}}), removing {{jna-4.4.0.jar}} in the process.
> > unable to install apache-cassandra-3.11.0 in linux  box
> > -------------------------------------------------------
> "
> [cassdb@alsc_dev_db bin]$ nodetool status
> -bash: nodetool: command not found
> [cassdb@alsc_dev_db bin]$ pwd
> /u01/Cassandra_home/apache-cassandra-3.11.0/bin
> [cassdb@alsc_dev_db bin]$ sh /u01/Cassandra_home/apache-cassandra-3.11.0/bin/cqlsh
> No appropriate python interpreter found.
> [cassdb@alsc_dev_db bin]$ service cassandra status



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message