cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Hornung (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CASSANDRA-13524) cassandra core connector - Guava incompatibility: Detected incompatible version of Guava in the classpath. You need 16.0.1 or higher
Date Thu, 11 May 2017 08:44:04 GMT
Michael Hornung created CASSANDRA-13524:
-------------------------------------------

             Summary: cassandra core connector - Guava incompatibility: Detected incompatible
version of Guava in the classpath. You need 16.0.1 or higher
                 Key: CASSANDRA-13524
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-13524
             Project: Cassandra
          Issue Type: Bug
            Reporter: Michael Hornung
         Attachments: build.sbt, error_log.txt

Hallo,

with my application I have a AKKA-http microservice which want’s to acess a cassandra database
table from scala.
Therefore I included this dependency in SBT:
         "com.datastax.cassandra" % "cassandra-driver-core"       % "3.2.0"
In my scalafile I have this coding:
--------------------------------------------------------------------------
….
import com.datastax.driver.core.Cluster
import com.google.common.util.concurrent._
….
    val cassandraHost    = "localhost"
    val keyStore         = "data4service"
    //setup cassandra
    val cluster = {
                    Cluster.builder()
                      .addContactPoint(cassandraHost)
                      .withCredentials("user", "password")
                      .build()
                  }
    //connect to cassandra keystore
    val session = cluster.connect(keyStore)
    val product = "123e4567-e89b-12d3-a456-426655440003"
    val select = s"SELECT quantity FROM stock WHERE product = $product"
    val result = session.execute(select)   
….
--------------------------------------------------------------------------

During build guava Version 19.0 is downloaded automatically

Unfortunately if I run my application I get this Error during runtime: 
--------------------------------------------------------------------------
com.datastax.driver.core.exceptions.DriverInternalError: Detected incompatible version of
Guava in the classpath. You need 16.0.1 or higher.
        at com.datastax.driver.core.GuavaCompatibility.selectImplementation(GuavaCompatibility.java:138)
        at com.datastax.driver.core.GuavaCompatibility.<clinit>(GuavaCompatibility.java:52)
--------------------------------------------------------------------------

that is not logical bevause Guava 19.0 is on the system. Can you help me?

Kind regards,
Michael




--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message