cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "yuqi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-13336) Upgrade the snappy-java version to 1.1.2.x
Date Thu, 16 Mar 2017 06:11:41 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-13336?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15927547#comment-15927547
] 

yuqi commented on CASSANDRA-13336:
----------------------------------

We are trying to enable Cassandra on AArch64 and found that Snappy Compress Library version
1.1.1.7 which was released in 2014 and has no aarch64 support. 
But it added support for AArch64 on the version 1.1.2.x.(https://github.com/xerial/snappy-java/pull/135).

So "snappy-java-1.1.1.7.jar" in "https://github.com/apache/cassandra/tree/trunk/lib" is needed
to upgrade to 1.1.2.x.
And the dependency in "build.xml"  is also needed to update to 1.1.2.x.
( <dependency groupId="org.xerial.snappy" artifactId="snappy-java" version="1.1.1.7"/>)




> Upgrade the snappy-java version to 1.1.2.x
> ------------------------------------------
>
>                 Key: CASSANDRA-13336
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-13336
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Configuration
>            Reporter: yuqi
>            Assignee: Jeff Jirsa
>             Fix For: 4.x
>
>
>  Snappy-java added support for AArch64 since version 1.1.2.x.(https://github.com/xerial/snappy-java/pull/135).



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message