cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Petrov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-12861) example/triggers build fail.
Date Mon, 14 Nov 2016 08:45:59 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-12861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15663180#comment-15663180
] 

Alex Petrov commented on CASSANDRA-12861:
-----------------------------------------

I've looked at the code and tried this trigger and does work. The only difference I've noticed
with the previous example was that the timestamp in micros isn't passed explicitly, although
I've checked the code and it picks current time in microseconds anyway. 

+1 

> example/triggers build fail.
> ----------------------------
>
>                 Key: CASSANDRA-12861
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-12861
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Yasuharu Goto
>            Assignee: Sylvain Lebresne
>            Priority: Trivial
>
> When I tried to build example/trigger on trunk branch, I found that "ant jar" fails with
an error like below.
> (Sorry for my language settings for ant. I couldn't find how to change it. The error
indicated here is a "cannot find symboll" error of RowUpdateBuilder).
> {code}
> Buildfile: /Users/yasuharu/git/cassandra/examples/triggers/build.xml
> init:
>     [mkdir] Created dir: /Users/yasuharu/git/cassandra/examples/triggers/build/classes
> build:
>     [javac] Compiling 1 source file to /Users/yasuharu/git/cassandra/examples/triggers/build/classes
>     [javac] 警告: 注釈プロセッサ'org.openjdk.jmh.generators.BenchmarkProcessor'から-source
'1.8'より小さいソース・バージョン'RELEASE_6'がサポートされています
>     [javac] /Users/yasuharu/git/cassandra/examples/triggers/src/org/apache/cassandra/triggers/AuditTrigger.java:27:
エラー: シンボルを見つけられません
>     [javac] import org.apache.cassandra.db.RowUpdateBuilder;
>     [javac]                               ^
>     [javac]   シンボル:   クラス RowUpdateBuilder
>     [javac]   場所: パッケージ org.apache.cassandra.db
>     [javac] エラー1個
>     [javac] 警告1個
> BUILD FAILED
> /Users/yasuharu/git/cassandra/examples/triggers/build.xml:45: Compile failed; see the
compiler error output for details.
> Total time: 1 second
> {code}
> I think the movement of RowUpdateBuilder to test has broken this build.
> https://github.com/apache/cassandra/commit/26838063de6246e3a1e18062114ca92fb81c00cf
> In order to fix this, I moved back RowUpdateBuilder.java to src in my patch.
> https://github.com/apache/cassandra/commit/d133eefe9c5fbebd8d389a9397c3948b8c36bd06
> Could you please review my patch?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message