cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jérôme Schneider (JIRA) <>
Subject [jira] [Created] (CASSANDRA-12752) Exception encountered during startup (CFMetaData.rebuild failed)
Date Thu, 06 Oct 2016 08:20:20 GMT
Jérôme Schneider created CASSANDRA-12752:

             Summary: Exception encountered during startup (CFMetaData.rebuild failed)
                 Key: CASSANDRA-12752
             Project: Cassandra
          Issue Type: Bug
         Environment: Cassandra 3.0.7, Debian Jessie. Java version 64 bits : 1.8.0_91-b14,
SSD software raid 1
            Reporter: Jérôme Schneider
            Priority: Blocker

We have a cluster of 3 cassandra 3.0.7. We have the following problems :
- ssltables was to big to be compress (not enough space left)
- we launch a sstablesplit which seems to work
- after we can't restart cassandra nodes we always have the same stacktrace  during the start
INFO  [main] 2016-10-05 18:02:47,346 - Initializing system_schema.aggregates
INFO  [main] 2016-10-05 18:02:47,353 - Initializing system_schema.indexes
ERROR [main] 2016-10-05 18:02:47,420 - Exception encountered during
java.lang.AssertionError: null
        at org.apache.cassandra.db.marshal.CompositeType.getInstance(
        at org.apache.cassandra.config.CFMetaData.rebuild( ~[apache-cassandra-3.0.7.jar:3.0.7]
        at org.apache.cassandra.config.CFMetaData.<init>( ~[apache-cassandra-3.0.7.jar:3.0.7]
        at org.apache.cassandra.config.CFMetaData.create( ~[apache-cassandra-3.0.7.jar:3.0.7]
        at org.apache.cassandra.schema.SchemaKeyspace.fetchTable(
        at org.apache.cassandra.schema.SchemaKeyspace.fetchTables(
        at org.apache.cassandra.schema.SchemaKeyspace.fetchKeyspace(
        at org.apache.cassandra.schema.SchemaKeyspace.fetchKeyspacesWithout(
        at org.apache.cassandra.schema.SchemaKeyspace.fetchNonSystemKeyspaces(
        at org.apache.cassandra.config.Schema.loadFromDisk( ~[apache-cassandra-3.0.7.jar:3.0.7]
        at org.apache.cassandra.config.Schema.loadFromDisk( ~[apache-cassandra-3.0.7.jar:3.0.7]
        at org.apache.cassandra.service.CassandraDaemon.setup( [apache-cassandra-3.0.7.jar:3.0.7]
        at org.apache.cassandra.service.CassandraDaemon.activate(
        at org.apache.cassandra.service.CassandraDaemon.main( [apache-cassandra-3.0.7.jar:3.0.7]
- it's now impossible to start a cassandra node. I tried to : upgrade to 3.0.9 (same error),
I reset system_schema (cassandra start) and I tried to launch sstablescrub on the corrupted
keystore (same stacktrace).

This message was sent by Atlassian JIRA

View raw message