cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-12505) Authentication failure for new nodes
Date Fri, 19 Aug 2016 16:13:20 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-12505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15428377#comment-15428377
] 

Mike commented on CASSANDRA-12505:
----------------------------------

I haven't found it in any Cassandra documentation regarding adding new node/DC, but after
I run nodetool repair -full, I was able to login into new node.

> Authentication failure for new nodes
> ------------------------------------
>
>                 Key: CASSANDRA-12505
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-12505
>             Project: Cassandra
>          Issue Type: Bug
>         Environment: Ubuntu 16.04
>            Reporter: Mike
>            Priority: Critical
>
> I added new data center with one node to a cluster. The cluster currently has 5 nodes
in 3 data centers. I changed the replication factor of system_auth keyspace according to the
number of nodes. I run nodetool repair and rebuild on new nodes, but I cannot login to the
new nodes. cqlsh reports the following error:
> {noformat}
> Connection error: ('Unable to connect to any servers', {'ip': AuthenticationFailed(u'Failed
to authenticate to ip: code=0100 [Bad credentials] message="Username and/or password are incorrect"',)})
> {noformat}
> I tried using both the SimpleStrategy and NetworkTopologyStrategy for the system_auth
keyspace without changes. I am still able to login into old nodes. nodetool status reports
that every node owns 100% of the system_auth keyspace. The log file does not show any errors.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message