cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Petrov (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-12242) Could not create trigger
Date Fri, 22 Jul 2016 11:53:20 GMT


Alex Petrov commented on CASSANDRA-12242:

Just tried it all. {{TriggerExecutor}} is a singleton, and classes are loaded on startup.
If jar is not there, it won't be visible, so you need to restart your instance to load it.

> Could not create trigger
> ------------------------
>                 Key: CASSANDRA-12242
>                 URL:
>             Project: Cassandra
>          Issue Type: Bug
>          Components: CQL
>            Reporter: RocWay Li
>         Attachments:
> I tried cassandra 2.2.6 and 3.7, both of them could not create triggers.
> It reports that the trigger class doesn't exist. But it actually does and is at the right
directory, the conf/triggers.
> I debugged the source code, and I found that SEPWorker is used to create triggers, but
it's thread is not a secure thread, which should be managed by cassandra's SecurityManager
and belongs to SecurityThreadGroup.
> When security validation failed, an exception will be thrown. That's direct cause for
creating triggers failed.

This message was sent by Atlassian JIRA

View raw message