cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Lerer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-11873) Add duration type
Date Thu, 16 Jun 2016 08:14:05 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-11873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15333329#comment-15333329
] 

Benjamin Lerer commented on CASSANDRA-11873:
--------------------------------------------

I am -1 on this. I think those syntaxes are more complex than needed. In my opinion {{now()
- 3d}} will be easily understood by everybody  and I do not think that there is a need to
have to write {{now() -3 day}}. In the case of CASSANDRA-11871 I found that the {{INTERVAL}}
syntax is making the query much more verbose and less readable: {{GROUP BY floor(time, INTERVAL
'1' HOUR)}}. 

> Add duration type
> -----------------
>
>                 Key: CASSANDRA-11873
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-11873
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: CQL
>            Reporter: Benjamin Lerer
>            Assignee: Benjamin Lerer
>              Labels: client-impacting, doc-impacting
>             Fix For: 3.x
>
>
> For CASSANDRA-11871 or to allow queries with {{WHERE}} clause like:
> {{... WHERE reading_time < now() - 2h}}, we need to support some duration type.
> In my opinion, it should be represented internally as a number of microseconds.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message