cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam Tunnicliffe (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CASSANDRA-11735) cassandra-env.sh doesn't test the correct java version
Date Mon, 09 May 2016 11:29:12 GMT

     [ https://issues.apache.org/jira/browse/CASSANDRA-11735?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sam Tunnicliffe resolved CASSANDRA-11735.
-----------------------------------------
    Resolution: Duplicate

> cassandra-env.sh doesn't test the correct java version
> ------------------------------------------------------
>
>                 Key: CASSANDRA-11735
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-11735
>             Project: Cassandra
>          Issue Type: Bug
>         Environment: Ubuntu 14.04
> openjdk 7 patch >=100
>            Reporter: Maxime Bugeia
>            Priority: Minor
>
> With the latest patch of openjdk, all nodetool actions fail and display "Cassandra 2.0
and later require Java 7u25 or later." because cassandra-env.sh test of java version is broken.
> Line 102:
> if [ "$JVM_VERSION" \< "1.7" ] && [ "$JVM_PATCH_VERSION"  \< "25" ] ; then
>     echo "Cassandra 2.0 and later require Java 7u25 or later."
>     exit 1;
> fi
> The second test cause all java patch >100 to be considered as inferior. One correct
syntax is "-lt" instead of "\<".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message